Acceso clientes de Latinoamérica

Contácto en toda Latinomérica

  • Llámanos o escríbenos vía WhatsApp+058 414.2357851
  • Email:info@hostingmediaweb.com

Cerrar ventana

Solicitud de Soporte

¡Instalé WordPress 5.5. y todo se fue a la &@$#/°s!!!

¡Instalé Wordpress 5.5. y todo se fue a la &@$#/°s!!!
  • 24
    Ago

¡Instalé WordPress 5.5. y todo se fue a la &@$#/°s!!!

Si tienes un sitio web desconfigurado, disfuncional o completamente inoperativo después de haberlo actualizado a WordPress 5.5, ¡no te asustes!. En esta publicación te explicaremos por qué WordPress 5.5 está deshaciendo sitios web y cómo solucionarlo.

¿Qué cambió en WordPress 5.5 que destruyó tu página?

WordPress 5.5 desactivó jQuery Migrate , una herramienta que WordPress ha incluido durante muchos años para ayudar a que los plugins y temas con código desactualizado aún se ejecuten correctamente. Al desactivar jQuery Migrate, muchos plugins y temas obsoletos ya no funcionan correctamente, lo que puede resultar en sitios web dañados.

¿Qué es jQuery Migrate?

jQuery Migrate es una biblioteca de JavaScript que ha ayudado a los desarrolladores de temas y plugins a preservar la compatibilidad del código jQuery obsoleto. Básicamente, jQuery Migrate ayudó a que el código antiguo se ejecutara correctamente en la versión actual de jQuery y posteriores. jQuery Migrate tenía la intención de ayudar a los desarrolladores durante el período de transición, para darles un tiempo a reemplazar su código por uno más moderno (o eliminarlo por completo).

¿Por qué WordPress 5.5 eliminó jQuery Migrate?

Las versiones anteriores de jQuery ya no son compatibles, por lo que es necesario que WordPress actualice los estándares de codificación. Mientras WordPress se prepara para hacer la transición a la actualización a la última versión compatible de jQuery, eliminar jQuery Migrate fue un primer paso necesario para asegurarse de que los plugins y temas estén actualizados y ya no utilicen código obsoleto.

¿Por qué mi sitio se daña después de actualizar a WordPress 5.5? (en algunos casos, no en todos)

En pocas palabras: porque estás ejecutando un plugin o tema que tiene un código desactualizado. Después de actualizar a WordPress 5.5, los plugins o temas obsoletos ya no funcionarán correctamente.

Dado que el código desactualizado en un plugin o tema ya no es compatible con el core de WordPress, puede dañar entonces tu sitio web. Nota: Los plugins y temas con código desactualizado representan un riesgo de seguridad importante para tu página, por lo que es una buena práctica no utilizar plugins y temas antiguos que hayan sido abandonados por sus desarrolladores; lo que hace wordpress 5.5. es “obligarte” a que esto no siga sucediendo.

Cómo arreglar sitios deshechos por WordPress 5.5

Si tu sitio se dañó después de actualizar a WordPress 5.5, hay algunos pasos que puedes seguir para arreglarlo.

1. Descarga e instala el plugin jQuery Migrate Helper

  1. Si tienes un sitio dañado después de actualizarlo a WordPress 5.5, instala el plugin jQuery Migrate Helper en tu página. Este plugin volverá a habilitar la herramienta jQuery Migrate que se eliminó en WordPress 5.5 y te proporcionará información sobre qué plugin(s) o tema podría estar funcionando mal.

Nota: El plugin jQuery Migrate Helper es una solución temporal para reparar tu sitio. Este plugin vuelve a habilitar la herramienta jQuery Migrate para darle a los autores de plugins y temas más tiempo para actualizar y probar su código, pero no debe usarse como una solución a largo plazo para arreglar tu sitio, ya que a medida que WordPress se siga actualizando puede llegar el momento en que esta ya deje de ser definitivamente una “solución temporal” o “pañito caliente”.

Después de instalar y activar el complemento jQuery Migrate Helper, verás este mensaje para explicarte que observarás advertencias mientras usas tu administrador de WordPress, pero no se mostrarán en el front-end de tu sitio.

2. Busca las advertencias generadas por el complemento jQuery Migrate Helper en tu área de administración de WP

Las páginas en tu administrador de WP generadas por plugins que tienen problemas en WordPress 5.5 deberían generar este tipo de mensaje de error. Este error te dará una indicación de qué plugins pueden estar causando problemas.

3. Utiliza la consola de tu navegador (F12) para encontrar errores adicionales

El plugin jQuery Migrate Helper también generará mensajes de error en la consola de tu navegador (ésta se abre al presionar F12 mientras navegas por tu site) para ayudarte a identificar qué otros plugins o tema ha dañado tu sitio.  Solo ten en cuenta que la resolución de problemas de esta manera es un poco más técnica.

4. Actualiza todos tus temas y plugins a las últimas versiones.

Si ves mensajes de advertencia, debes verificar el tema o plugin que los generó, para poder actualizarlos. Con suerte, habrá una actualización que puedas instalar.

  • Si descubres que no estás ejecutando la última versión de un tema o plugin, actualízalo a la última versión . Las actualizaciones disponibles se mostrarán en tu panel de administración de WordPress en la página Actualizaciones.
  • Si estás ejecutando una versión desactualizada de un plugin o tema premium, deberás agregar su clave de licencia o comprar una nueva licencia para actualizar a la última versión. La mayoría de los plugins y temas premium usan claves de licencia para proporcionar actualizaciones a través de su panel de administración de WordPress, por lo que deberías ver las actualizaciones disponibles después de agregar una clave de licencia.

Si la actualización de tus plugins o temas corrige tu sitio dañado y no hay más advertencias, desactiva entonces el jQuery Migrate Helper.

5. Si no hay ninguna actualización disponible, comunícate con el desarrollador del tema o del plugin para actualizar su código.

Desafortunadamente, para que puedas continuar usando uno de los temas o plugins con código desactualizado, el desarrollador del tema o plugin deberá actualizar su código. Si no obtienes respuesta, deberás eliminar el plugin o el tema, ya que el código no será funcional en las versiones de WordPress en el futuro.

Los problemas de seguridad del uso de plugins y temas obsoletos

Ya mencionamos esto, pero es lo suficientemente importante como para reiterarlo: como una mejor práctica de seguridad de WordPress, no debes ejecutar versiones desactualizadas de tus plugins o temas.

La ejecución de plugins y temas obsoletos es la razón número 1 por la que los sitios de WordPress son pirateados.

Los lanzamientos de versiones nuevas a menudo incluyen parches importantes para las vulnerabilidades de seguridad, por lo que debes mantener todo actualizado.

El riesgo de seguridad de ejecutar plugins y temas obsoletos se ha convertido en un problema tan crítico que WordPress 5.5 ahora incluye actualizaciones automáticas para complementos y temas .

Por qué las copias de seguridad de WordPress son tan importantes

Antes de actualizar a cualquier versión principal de WordPress, siempre es una buena idea ejecutar una copia de seguridad completa de tu sitio. Junto con la eliminación de jQuery Migrate, WordPress 5.5 introdujo cambios adicionales como actualizaciones automáticas de plugins y temas. Es por eso que tener un plan de respaldo sólido de WordPress es más importante que nunca, pues pudiera suceder que alguna de estas actualizaciones dañe tu sitio.

Directorio de Web hosting Venezuela